When the user press Submit, the data will be emailed to you...
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SpreadsheetConverter provides two services. Both of these services work with any type of web server. You publish the form on your site and our server handles the routing of the email. 

1. A free service which is included in the base price of SpreadsheetConverter. 

2. An advanced service which creates much better looking emails and where the data can be stored in a database. 

The free service sends you an email with the fields and values of the form. Tip: Name the cells in Excel to make the emails more understandable. 

The advanced service supports several different formats. One is a flat copy of the web page as it looked when the user pressed submit. The monthly fee will be in the range $10-$20. 

If you want, the advanced service will store the submitted data in a database for later retrieval. Compiled reports, for example all submits made last week, can also be created and automatically be sent. Several formats are supported, for example Excel files. 

Using the service is very simple and takes less than 1 minute to get started. Next time you convert your spreadsheet, select to configure Submit and request a receiver code. Wait for the email with the receiver code, and then enter the receiver code into the SpreadsheetConverter wizard. Click here to read the User's Guide for more information.
Until the first complete release of the advanced service is available, you can use the advanced service without any cost. 

The web page generated by SpreadsheetConverter is a standard web form. Thus, if you a are professional developer, you can use the generated web page together with any form solution. You only have to set the action-attribute of <form> element.

Below, you see the email you will get when using the advanced service.

Click here for more information.
	Subject: 
	Data submitted Book1.xlsx 

	From: 
	support@spreadsheetconverter.com 

	Date: 
	Montag, 17. September 2007 04:45 

	To: 
	you@youremail.com 


Top of Form
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Bottom of Form

Submit received from 76.109.243.245 (c-76-109-243-245.hsd1.fl.comcast.net) at 2007-09-17T04:45:30. 
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Quick start guide

How do I download SpreadsheetConverter?

1. Point your browser to www.spreadsheetconverter.com. 

2. Follow the links in the left-hand column to the download location for the appropriate version of SpreadsheetConverter. 

3. When you get to the download page, the download process should start automatically. If it doesn’t, click on the Download Now! button. 

4. Select Open or Run to execute the installation program immediately after download. 

How do I install SpreadsheetConverter?

1. If you selected Open or Run during download, the installation process should start automatically. Otherwise use the Windows Explorer to navigate to the folder containing the downloaded file and double-click on the file name, e.g. xlew_latest.exe. 

2. Carefully read through the license agreement, then click “I Agree” to indicate that you accept its terms. If you don’t, press “Cancel” to terminate the installation. 

3. The installation program suggests a default location for the program files. Press “Install” to accept the default location. 

4. When the Excel Add‑in is installed into Excel, you must approve the use of a potentially insecure macro. This process is slightly different depending on your Excel version and security setting. Ensure that you check the checkbox “Always trust macros from this source” if available, then press “Enable Macros” to approve the installation. 

5. When the installation of SpreadsheetConverter is completed, press “Close” to close the installation program. 

6. If you intend to install SpreadsheetConverter to Java, you should also install the Java 2 Platform, Standard Edition, Software Development Toolkit (J2SE SDK) version 1.3.1 or later on the same PC. The J2SE SDK is available for download at http://java.sun.com/downloads/. 

How do I convert a spreadsheet to HTML?

1. Ensure that Excel is started. 

2. If you intend to create a server-based solution, ensure that the prerequisite server environment is set up using the instructions in the section The SpreadsheetConverter server environment below. 

3. Open the spreadsheet you want to convert. 

4. Verify that the SpreadsheetConverter menu is available in the menu bar. 

5. In the SpreadsheetConverter menu, click “Convert”. 

6. Press “Next” to start the SpreadsheetConverter wizard. 

7. If the “Select output format” page is included in the wizard, select “Pure HTML/JavaScript”. 

8. On the “Select Cells” page, select “Automatic detection” as the selection method. For “Which worksheets?”, select “Selected”. Press “Next” to advance to the next page of the wizard. 

9. On the “Presentation and Interaction” page, just press “Next” to advance to the next page of the wizard. 

10. On the “Select location” page, verify the folder location for the web page that will be created by SpreadsheetConverter. Press the “…” button if you want to change the defaults. Press “Next” to advance to the next page of the wizard. 

11. Press “Finish” to begin the conversion process. 

12. After conversion, a “Messages and Errors” window appears. In most cases there are only informational messages. For troubleshooting, go to the Troubleshooting section of this manual. 

13. In most cases, the generated web page is automatically opened in your default web browser. Verify the results of the conversion. If you are unhappy with the results you should consider modifying the original spreadsheet in Excel before you attempt to modify the web page. 

How do I add an SpreadsheetConverter web page to my web site?

1. Ensure that the file is physically included in your web site, i.e. that it is transferred to the same server as the other web pages in the web site using file transfer, a site management utility or a content management system. This guarantees that the page is physically accessible when requested by one of the users of the web site. 

2. Link the page to the rest of your site. You will need at least one link to the page so that users can navigate to it. If your web site has a menu or similar navigation structure you may want to insert it also on the SpreadsheetConverter page. 

3. Give the SpreadsheetConverter page the same look-and feel as the rest of your site. Open the SpreadsheetConverter page in your favorite web page editor and format it so that it looks like the other pages on your web site. 

Note: SpreadsheetConverter is shareware, i.e. “try before you buy”. Publishing on the web is not included in the free functionality. You must have a license for SpreadsheetConverter before you publish converted spreadsheets on the web. 

How do I uninstall SpreadsheetConverter?

1. Open the “Add/remove programs” control panel (Start > Settings > Control Panel > Add/Remove Programs). 

2. Locate “SpreadsheetConverter (remove only)” in the list of programs. 

3. Press “Change/Remove”. 

4. Press “Uninstall” to confirm the uninstall operation. 

Introduction

The VisiCalc spreadsheet was one of the first killer applications for personal computers. The reason for this is obvious; you didn’t need to be a programmer to use the enormous functionality in a spreadsheet. The nature of “what you see is what you get” calculations made it easy for both individuals and businesses to create powerful, yet easy-to-use spreadsheets. 

SpreadsheetConverter was developed with this same WYSIWYG philosophy in mind. SpreadsheetConverter converts Microsoft Excel spreadsheets into web pages that look and function just like the original spreadsheet. For details on the conversion process, see Appendix 1: Conversion details.

Excel's own "save as HTML" allows you to create a non-interactive web page. Excel then creates a static table with all the values you see in Excel. In non-interactive web pages created by Excel, cell values cannot be changed. 

If you instead select to save your spreadsheet with interactivity, you will be able to change the contents of the cells, and the values will be recalculated. Microsoft does this by using a very large ActiveX component (2MB in size). The ActiveX component only supports certain client environments (mainly Windows) and may only be used in clients with a license for the Microsoft Office package. 

In contrast, SpreadsheetConverter creates an interactive web page by using embedded JavaScript instructions to do the calculations. Web pages created by SpreadsheetConverter run on any browser, on any OS, and without extra run-time licenses.

SpreadsheetConverter: key features

When developing SpreadsheetConverter we have focused on the following: 

· Ease of use. No programming, or experience of programming is required to produce calculating web pages. 

· Maintain the Excel look-and-feel. The resulting web pages have the look-and-feel of the original Microsoft Excel spreadsheets. 

· Support for most Excel functions. All but a few advanced financial and statistical functions are automatically converted to JavaScript instructions embedded in the resulting web page. 

· Live 2d-charts. Give the user immediate feedback with pie, column, bar, line and scatter-charts. 

· Create web forms with validation. Design the form in Excel and start collecting data from your website visitors. 

· Built-in submit support. No need to learn how to configure your web server to accept submits from forms. 

· Create easy to use interfaces. Increase the usability of forms using checkboxes, radio buttons, drop-down menus and list boxes 

· Production of compact web pages. The resulting web pages are very compact in order to reduce download times. 

· Production of quick running web pages. The resulting web pages perform calculations quickly, even if they were generated from large advanced spreadsheets. 

· Support for a wide range of target environments: Windows, Linux, Unix, Macintosh and embedded systems like set-top boxes. The resulting web pages work perfectly in all modern browsers. 

Benefits of using SpreadsheetConverter

Using SpreadsheetConverter will save you time and money and your customers will receive increased service and better quality. Other key benefits are: 

· Incredibly easy to use. Coding calculating web pages directly using JavaScript is very costly and time consuming, and they are difficult to maintain. SpreadsheetConverter makes interactive calculating web pages feasible. 

· A 10-fold increase in productivity. The enormous gain in productivity comes from being able to use Excel, with all of its built-in functions, as a tool for developing calculating web pages. The conversion to web format with SpreadsheetConverter is simple and fast. 

· Quick and easy updates to web pages. The process of updating your web pages is made both quicker and easier: simply update the spreadsheet, run SpreadsheetConverter, and then distribute the new web page. 

· Improved quality due to easier testing in Excel. The web pages created by SpreadsheetConverter maintain the exact calculation logic of the original, tested Excel spreadsheets. 

· Support for many different technical environments. The web page format created by SpreadsheetConverter has been tested in a wide variety of different browsers and operating systems. Web pages generated by SpreadsheetConverter are in daily use among its many customers. You never need to worry about technical compatibility. 

· Reduced consultancy fees. In-house personnel can use SpreadsheetConverter; no programming or advanced web skills are required. No need for paying external consultant fees. 

· Suitability for all. SpreadsheetConverter is designed to be suitable for everyone to use, individuals, businesses, governments and associations. 

Client- and server-based solutions

SpreadsheetConverter can convert spreadsheets to standalone programming code that runs either in the browser or in the server. 

         In a client-based solution, the programming code is stored in the web page and executed by the user’s web browser. Formulas and constant values are visible in the web page source code. Recalculation can occur automatically whenever the user changes a cell. The client-based solution offers better interactivity for small and medium sized spreadsheets. Client-based solutions are also more scalable and reduce the network traffic, since the server only has to send the web page once.

         In a server-based solution, the programming code is stored and run on the web server. Formulas and constant values are not visible to the user. Recalculation must be requested manually by pressing a button after a group of cells have been updated. Server-based solutions simplify advanced integration with back-end systems, e.g. databases. Server-based solution offers increased security, since the calculations are done on the server, and better performance for large spreadsheets.

The different versions of SpreadsheetConverter

SpreadsheetConverter is currently available in three versions:

· SpreadsheetConverter to HTML (generates client code)

The spreadsheet is converted into a standalone web page with embedded JavaScript that allows the web page to function exactly like the spread​sheet when it is opened in any modern JavaScript-capable web browser. 

· SpreadsheetConverter to ASP and ASP.NET (generates server or client code)

The spreadsheet is converted into a standalone ASP or ASPX file that can be run in Microsoft Internet Information Server (IIS). 

· SpreadsheetConverter to Java (generates server or client code)

The spreadsheet is converted into a Java program that can be run on any JSP-capable web server, and a web page used to access the Java program. 

The server-based solutions require a much more complicated operating environment than the client-based solution. We recommend that you use SpreadsheetConverter to HTML unless you are certain you need a server solution.

Installation

Prerequisite software

· SpreadsheetConverter uses Macromedia Flash to show charts. Most users already have a suitable version of Flash installed. The Flash browser plug‑in is free, and is automatically downloaded and installed if required. If a user doesn’t permit installation of the plug‑in, the web page will still work, but charts will not be visible. 

· If you intend to install SpreadsheetConverter to Java, you should also install the Java 2 Platform, Standard Edition, Software Development Toolkit (J2SE SDK) version 1.3.1 or later on the same PC. The J2SE SDK is available for download at http://java.sun.com/downloads/. 

· In a server-based solution, you must establish the required server environment before you can create server-based solutions. For details, see The SpreadsheetConverter server environment below. 

First-time installation

Download the SpreadsheetConverter program file

Download the appropriate version of SpreadsheetConverter using the instructions in the Quick start guide above.

Start the installation

If you selected Run or Open during download, the installation process should start automatically. Otherwise use the Windows Explorer to navigate to the folder containing the downloaded file and double-click on the file name, e.g. xlew_latest.exe. 

Approve the license agreement
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Carefully read through the license agreement, then click “I Agree” to indicate that you accept its terms. If you don’t, press “Cancel” to terminate the installation.

Select program folder
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The installation program suggests a default location for the program files. Press “Install” to accept the default location.

Under special circumstances you may want to install the program in a different location than the default. If you are upgrading a previous installation, you should either uninstall the old version first, or install the new version at the same location as the old version. Press the Browse button to select another installation folder. 

Enable macros
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When the Excel Add‑in is installed into Excel, you must approve the use of a potentially insecure macro. This process is slightly different depending on your Excel version and security setting. 
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The security warning above appears when the Excel security level is set to High. Ensure that you check the checkbox “Always trust macros from this source” if available, then press “Enable Macros” to approve the installation.

Note: If you decide to disable macros for security purposes, SpreadsheetConverter will not be installed into Excel and cannot be used.

Finish the installation
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When the installation of SpreadsheetConverter into Excel is completed, Press OK.

Locate the window for the SpreadsheetConverter installation program (it should look like the example below). 
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Press the “Close” button to end the installation program.

Installing updates

To upgrade to later versions of SpreadsheetConverter, simply repeat the installation process described above using the updated program file. You don’t need to uninstall the old version before you install the new one. The installation program will automatically replace old files and remove redundant files. Note: version 3 does not replace version 2. To uninstall version 2, follow the instructions in Uninstalling the program below.

Uninstalling the program

1.      Open the “Add/remove programs” control panel (Start > Settings > Control Panel > Add/Remove Programs). 
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2.      Select “SpreadsheetConverter Version 3 (remove only)” in the list of programs.

3.      Press “Change/Remove”.
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4.      Press “Uninstall” to confirm the uninstall operation.

Consider the remaining registry information

The uninstallation of SpreadsheetConverter will not remove information it may have saved in the Windows registry, e.g. the registration key, user settings etc. If you reinstall SpreadsheetConverter later, it will reuse the old registration key and settings. This is in conformance with Microsoft recommendations. The remaining registry information occupies a negligible amount of hard disk space. Please contact support@spreadsheetconverter.com if you need instructions on how to remove the redundant registry entries. 

Note: The fact that the SpreadsheetConverter registration key remains in a computer does not override the license agreement. If you have a one-user license, you may install and use SpreadsheetConverter on only one computer at a time.

The SpreadsheetConverter server environment

In a server-based solution, the SpreadsheetConverter converter generates programming code to be run on Microsoft’s Internet Information Server (IIS) or on a web server that supports JSP pages and Java Beans (e.g. Tomcat). Describing the complete server installation in detail is beyond the scope of this document. Below is a short summary of the most important issues.

SpreadsheetConverter to ASP and ASP.NET

To use SpreadsheetConverter with ASP.NET requires the Microsoft .NET framework. If you plan to install IIS, uninstall the .NET-framework first, then install IIS using the instructions below, then install the .NET framework again.

SpreadsheetConverter to ASP and ASP.NET requires IIS, which is provided with all current versions of Windows except Windows XP Home. IIS is not always installed during Windows installation. To install IIS manually, open the “Add/Remove Programs” control panel and select “Add/Remove Windows Components”. Tick the checkbox next to IIS in the list and press “Next” to proceed through the installation wizard.

SpreadsheetConverter to Java

The Java version of SpreadsheetConverter requires the following:

· A web server capable of supporting JSP pages and Java Beans, e.g. the Tomcat server from the Apache Foundation available for download at http://www.apache.org/dist/jakarta/tomcat-4/. 

         The Java 2 Platform, Standard Edition, Software Development Toolkit (J2SE SDK) version 1.3.1 or later, available for download at http://java.sun.com/downloads/.

Tomcat issues

When you convert a spreadsheet a second time, the converted files will be copied to the Tomcat server environment. However, Tomcat does not automatically reload the class-file, so the web page will not work.

There are two circumventions to this problem:

· Restart the Tomcat server (put the Tomcat start and stop icons on the server’s desktop for fast restart). 

· Request that Tomcat reloads the whole web page, e.g.: http://localhost:8080/manager/reload?path=/examples 

Since this is rather time-consuming, we recommend that you use a client-based solution to get the output exactly the way you want it before you convert the spreadsheet for a server-based solution.’

Using SpreadsheetConverter

Spreadsheet conversion wizard

Open the spreadsheet and start the conversion

Ensure that Excel is started.

If you intend to create a server-based solution, ensure that the prerequisite server environment is set up using the instructions in the section The SpreadsheetConverter server environment above.

Open the spreadsheet you want to convert. 

If you have previously attempted to convert this spreadsheet, you may have found that it required manual designation of input cells. In this case, you should add a suitable fill color to all input cells before starting the SpreadsheetConverter wizard. 
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Verify that the SpreadsheetConverter menu is available in the Excel menu bar. If it isn’t, press the Esc key on the keyboard to ensure that any context-specific menus are deactivated. Excel automatically disables the menu while you are editing a cell.
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The SpreadsheetConverter menu has the following entries

· Convert, Last error report: Convert is used to start the conversion. Last error report reopens the last list of errors. 

· Mark input cell, Create one of several options, Create Boolean control are used to simplify creation of advanced user interfaces with checkboxes, drop-down menus, radio buttons etc. These are described at Creating better user interfaces 

· Manual Acrobat PDF and HTML will open this manual. If you want to print the manual, the PDF-format is recommended. 

· Enter license key will let you register your version, see Register your copy of SpreadsheetConverter. 

· Purchase full license key will open a web page where you can purchase a license. Note that this entry will still be there after that you have registered your copy. 

· Purchase upgrade license. If you have version 2 and want to upgrade to version 3, you can buy a license here. 

· Check for update. Check if your installed version is the latest version. If it isn’t, you will be told how to download the newer version. 

In the SpreadsheetConverter menu, click “Convert”.

Register your copy of SpreadsheetConverter

If you have already registered your copy of SpreadsheetConverter, skip this section and proceed to Start the SpreadsheetConverter wizard below. If you haven’t yet registered your copy of the program, a window similar to the one below will appear. 
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If you haven't registered the program, SpreadsheetConverter works in trial mode. The only restrictions of the trial version are:

· The trial version only works for 30 days. 

· You are not allowed to use the web pages created by the trial version for any purpose other than evaluation. 

· Only cells on the first ten rows of the first sheet will be part of the web page. 

As soon as you register the program, all these restrictions are removed (there is no need to reinstall the program). Once you’ve purchased a license, there are no additional costs and there are no royalties to pay when you distribute the resulting web pages. 

If you want to order a registration key for SpreadsheetConverter, click “Order a license online”.

If you have a registration key and want to register this copy of SpreadsheetConverter, click “Enter registration key”.
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Copy the license key from the e‑mail or web page where you got it and paste it into the first cell of the “license key” field. Enter the e‑mail address in the “Email address” field that you used when purchasing the license key. Press OK to register your copy of SpreadsheetConverter. 

Press “OK” in the “License key accepted” window. 

Start the SpreadsheetConverter wizard
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Press “Next” to start the SpreadsheetConverter wizard.

Select output format

This step is only present in the multi-format versions of SpreadsheetConverter, and allows you to select one of the following (some choices may not be available in your particular version of SpreadsheetConverter):

· Pure HTML/JavaScript.

This is the standard format used in a client-based solution. Use this setting while you enhance a spreadsheet to obtain the best output. When you are satisfied, generate the final output format intended for the server. 

· ASP.NET/ASP

This is the server-based format for an ASP solution, i.e. when using SpreadsheetConverter to ASP and ASP.NET to create programming code for an IIS server with or without the .Net framework. Use “ASP.NET with C#/VB.NET code behind” if you know how to program ASP.NET and intend to use backend integrations, e.g. reading initial values from a database or storing results in a database. 

· JavaBeans for calculation, JSP with JavaScript for GUI.

This is the server-based format for a Java solution, i.e. when using SpreadsheetConverter to Java to create programming code for a JSP-capable web server. 

Select cells

Select which sheets to include in the web page
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The “Select Cells” dialog allows you to select which sheet tabs in the workbook to make available in the resulting web page. Each additional tab may make the converted web page bigger or slower, so don’t create more sheet tabs than necessary. To make only the currently active worksheet visible in the web page, select “Selected sheets(s)” for the best performance. 

If you want to create sheet tabs for a subset of the worksheets in the workbook, do the following:

· Press Cancel to stop the SpreadsheetConverter wizard. 

· In Excel, click on the sheet tab at the bottom of the first sheet you want to include in the resulting web page. 

· Hold down the Ctrl key on the keyboard and click on the sheet tab of the second and subsequent sheets you want to include. 

· Start the SpreadsheetConverter conversion wizard again. 

· Select “Selected sheet(s)” in the “Create tabs for” section of the “Select cells” dialog. 

Select the input cells

You may also select the spreadsheet cells that are to be editable by the user. In most cases, SpreadsheetConverter will be able to determine this automatically by looking at the contents of each cell. If this is the first time you are converting this particular spreadsheet to html, try using automatic detection first. Select “Automatic detection” as the selection method, then press “Next” to advance to the next page of the wizard. Skip the rest of this section for now and continue with Presentation and Interaction below.

If you wish to prevent certain fields from modification by the user, or if you wish to add extra input fields that may not be obvious to SpreadsheetConverter (e.g. for extra lines in address fields), you need to use one of the two methods that SpreadsheetConverter uses for manual designation of input cells. This is also necessary when you create forms using SpreadsheetConverter. See http://www.spreadsheetconverter.com/article/articleview/35/1/1 for more information.

If your worksheet uses Excel’s built‑in protection mechanism, the input cells have already been explicitly “unlocked” by the creator of the spreadsheet. In this case, SpreadsheetConverter can use this information to determine which cells to use for input. You need to unlock the worksheet before conversion and select the “Unlocked cells are input cells” option on the “Select cells” page in SpreadsheetConverter. (For more information on how to protect cells and worksheets in Excel, use the help index in Microsoft Excel).

You can also use fill coloring to explicitly “open” cells for input from the user. With this method you assign a special background color to just the input cells. During conversion, SpreadsheetConverter locks all cells except the cells with the selected fill color. 

To apply the selected fill color to each cell, set the Format > Cells > Patterns > Cell shading from the Excel menu bar or use the “Formatting” toolbar’s [image: image20.jpg]


 icon. Ensure that you apply the selected fill color to all the cells that should be open for input (but not to any other cells). 

Save the spreadsheet and then run the SpreadsheetConverter wizard again. In the “Select cells” window, select “Using coloring”, then press the “…” button to select the fill color that you have already applied to all the input fields. 
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If you don’t want the special fill color for input fields to appear in the converted web page check the “Ignore background color…” check box. 

Press “OK” when you have selected the correct color.

Press “Next” to advance to the next page of the wizard.

Presentation and Interaction

Formatting in Excel vs. formatting by browsers

One of the many strengths of the spreadsheet concept is the easy handling of rows and columns. When creating a spreadsheet you can tailor the exact appearance of each row and column, including height, width, borders and headings. There are also numerous ways to format individual cells, including how numbers are displayed, what fonts are used and what colors are used for text and background. 

When spreadsheets are converted into web format, they enter the realm of competing web browsers. Unfortunately, no browser is identical to the other, and a web page will inherently appear somewhat different in each browser. This is part of the natural behavior of the world-wide web. 

When SpreadsheetConverter converts a spreadsheet to html, it is forced to make certain compromises when it comes to formatting. When compared to the original spreadsheet in Excel, the web page created by SpreadsheetConverter will not be an identical twin regardless of which browser you use to view it. In fact, it will look slightly different in every browser, and often different between versions of the same browser. Once again, this is a natural consequence of entering the web environment. In most cases the result is good enough.

The Presentation and Interaction page
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The “Presentation and Interaction” page of the SpreadsheetConverter wizard allows you to control some of the compromises made during conversion. Press the “Configure layout and recalculation…” button if you want to modify the appearance of the converted web page. To configure the toolbar and submission options in the web version of the spreadsheet, press the “Configure toolbar and submit…” button. 

Settings for spreadsheet layout
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Dynamic layout

SpreadsheetConverter can attempt to give the rows and columns in the web version of the spreadsheet approximately the same height and width as in Excel, or allow the browser to calculate the column width automatically. If you select Fixed layout, SpreadsheetConverter toces the browser to use the exact layout of the spreadsheet to the converted web page. Overriding the browser’s own automatic formatting in this way may cause unexpected results, e.g. that input fields might become too small. In this case you may need to adjust the formatting options in the Excel version of the spreadsheet before you convert it to web format.

Fixed layout is only supported by Internet Explorer.

Borders around input cells

This setting controls the appearance of input cells, i.e. the cells in the spreadsheet that the user may modify. Use the setting that you think produces the best result. 

Automatic Recalculation

To provide correct information, the value of each cell in the web format spread​sheet must be recalculated when changes have been made to one or more of the input cells open to the user. In most cases, it is recommended that this recalculation occur automatically when the user moves to the next input field. 

However, if the spreadsheet is large, recalculation may be time-consuming and distracting. It this case, it may be better to perform the recalculation when the user explicitly requests it by pressing a button. The main disadvantage of manual recalculation—apart from the manual intervention required—is that it may be easy to forget to recalculate the values in the spreadsheet. In this case, the user may inadvertently base decisions on values that are incorrect. We strongly recommend that you design each spreadsheet so that automatic recalculation is possible, e.g. by separating content into separate worksheets. 

By default, SpreadsheetConverter recalculates worksheets automatically unless they are so big that recalculation between cell modifications would cause an undesired delay in data entry. Use the Automatic Recalculation setting to adjust the way SpreadsheetConverter recalculates cell values:

· Smart Enable – Always perform automatic recalculation, except for very large worksheets. 

· Enable – Always perform automatic recalculation. 

· Disable – Never perform automatic recalculation. SpreadsheetConverter will include an Update button in the toolbar for manual recalculation. 

Automatic recalculation is only available for client-based solutions. When creating server-based pages, this setting is ignored.

Press “OK” to save the advanced layout settings.

Configuring the toolbar

SpreadsheetConverter can insert a toolbar in the converted web page. The toolbar may include buttons for manual recalculation, printing etc, and sheet tabs for navigation between sheets in the workbook.
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The toolbar and its location can be configured in the SpreadsheetConverter wizard. 
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The toolbar can be inserted above the spreadsheet, below it or both. 

Select one of the available themes to modify the appearance of the button bar. 

Select which buttons you want to include in the toolbar. Modify the default text for each button, if necessary.

· The Update button recalculates the cell contents in the spreadsheet. If Automatic recalculation is enabled, this button is redundant. 

· The Reset button 

· The Print Sheet button prints the current sheet. 

· The Print All Sheets button prints all sheets in the workbook. 

· The Submit button sends the updated spreadsheet to a server. It is mainly used for online forms created with SpreadsheetConverter. The submit options are described in detail in the next section of this document. See Creating an interactive form as a web page below for more information on how to use the submit function. 

Press “Next” to advance to the next page of the wizard.

Submit parameters

When you create a form, you want to be able to collect the data. The browser cannot email the form data to you directly, but it can use server functionality on the network to convert the form contents into as an email. The standard solutions for this conversion are typically rather hard to configure, and your email address may need to be included in the web page, inviting spam.

To avoid these drawbacks, SpreadsheetConverter provides a built-in solution which is easy to configure and doesn’t expose your email address. The submitted data is sent to one of our servers, which converts the form fields into an email and sends it directly to you. To use this service, you need a receiver code provided by us. When forms are submitted using this receiver code, the form fields are sent by email to a predefined email address. 

The Configure Submit window

To configure the submit parameters, start the SpreadsheetConverter wizard, advance to the Presentation and Interaction page, and click ”Configure toolbar and submit...”. Then click ”Configure submit...” to open the Submit parameters window.
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To request a receiver code, press the ”Request free receiver code” button and type the email address for the completed forms. 
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Your trial receiver code is sent by email to this email address. 

Select the free or advanced service and enter the receiver code into the corresponding text box in the Submit parameters window. If you use the free service, it is very important to name the cells. See Naming cells

In the future, there will be a minimal monthly charge for using the advanced service to send the data to you. Before then, the following functionality will be added: 

· Submits are compiled into reports, all submits for a given period, for last week etc. 

· The reports are available both as web pages and as spreadsheets. 

· Excel reports are emailed directly to you for easier handling on your side. 

We will notify you when development is complete. Until then, the advanced service is free. For more information about pricing of the Advanced service see http://www.spreadsheetconverter.com

Using your own script for SpreadsheetConverter toms

If you prefer to use your own script to process the updated html form, enter the URL to that script in the URL field. The script will be sent the following parameters:

· xl_version=3.0.0 – identifies the file format 

· (name1)=(value1) 

· (name2)=(value2) 

· etc 

where (name1) is the name assigned to the first input cell in the form and (value1) is the value in that cell. If a worksheet contains two input fields, “name” and “release”, the parameters sent to the script will be:

?xl_version=3.0.0&name=exceleverywhere&release=3.0.0
Data is encoded according to the http post standards, e.g. a space is represented as “%20”. Please contact our support department if you need help on how to decode the query string of an http post operation.

If a cell hasn’t been assigned a name, SpreadsheetConverter will refer to it using a four-part code:

1. the code always begins with “p” 

2. relative sheet number in the workbook, e.g. “1” for the first sheet 

3. column 

4. row 

The first cell in the first sheet is referred to as “p1A1”.

Press OK to configure the submit parameters.

Select location

Pure HTML/JavaScript

If you are using SpreadsheetConverter to HTML or have selected the “Pure HTML/JavaScript” as your output format, the Select location page looks like this:
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Verify the folder location for the web page that will be created by SpreadsheetConverter. 

The web page is saved in two formats:

· A subdirectory containing the web page in html format, together with all the required pictures and charts. 

· A zip file with the same directory and files in compressed format. 

When you publish the web page on a web server, you must include all files in the folder created by SpreadsheetConverter. To avoid file name conflicts, we recommend that you upload the entire folder and link to the page inside the folder. If you want to send the web page to someone else, remember to send the zip file to ensure that all required files are included.

Press the “…” button if you want to change the default location. Navigate to the proper folder and press OK. 

Press “Next” to advance to the next page of the wizard.

JavaBeans for calculation, JSP with JavaScript for GUI

If you are using SpreadsheetConverter to Java and are creating a server-based solution, the Select location page looks like this:
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First, SpreadsheetConverter creates the JSP file, the actual web page that you will open in your web browser to view the spreadsheet on the web. The JSP file is used to access the Java programming logic. The JSP file must be accessible by the web server. You can either create the file in your local file system and move it to the server, or place the file directly on the server if you have file-sharing access to its disks. In the example, the JSP file is placed on the “Meg” server at \\Meg\Meg_E\Program_Files\Apache_Group\Tomcat_4.1\webapps\examples\jsp. To change the location of the JSP file, press the “…” button, navigate to the proper folder and press OK. You may of course run the web server in your local PC. In that case the JSP file will typically be located in a folder on your C: disk. 

Second, SpreadsheetConverter creates the Class file, which contains the Java source code created from your spreadsheet. The class file is also available for including into projects. The class file must be accessible by the web server. You can either create the file in your local file system and move it to the server, or place the file directly on the server if you have file-sharing access to its disks. In the example, the class file is placed on the “Meg” server at  \\Meg\Meg_E\Program_Files\Apache_Group\Tomcat_4.1\webapps\examples\WEB-INF\classes. To change the location of the class file, press the “…” button, navigate to the proper folder and press OK. You may of course run the web server in your local PC. In that case the class file will typically be located in a folder on your C: disk.

Third, you can specify a folder for the temporary Java file. If you don’t, a default location will be used. Observe the usage restrictions for the source file in the SpreadsheetConverter End-User License Agreement.
Fourth, you need to specify a Java package name for some web servers (e.g. Tomcat). We suggest you use the package name “com.xlew”. 

When conversion is complete, SpreadsheetConverter can automatically open the converted web page in your browser. Enter the http address to the folder containing the JSP page in the URL used to open resulting JSP page field.

Press “Next” to advance to the next page of the wizard.

ASP and ASP.NET

If you are using SpreadsheetConverter to ASP and ASP.NET and are creating a server-based solution, the Select location page looks like this:
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First, SpreadsheetConverter creates the ASP or ASPX file, the actual web page that you will open in your web browser to view the spreadsheet on the web. The ASP file is stored on the server and contains all the required programming logic. The ASP file must be accessible by the IIS web server. You can either create the file in your local file system and move it to the server, or place the file directly on the server if you have file-sharing access to its disks. In the example, the ASP file is placed on the Meg server at \\Meg\Meg_E\www\prices. To change the location of the ASP file, press the “…” button, navigate to the proper folder and press OK. You may of course run the web server in your local PC. In that case the ASP file will typically be located in a folder on your C: disk.

When conversion is complete, SpreadsheetConverter can automatically open the converted web page in your browser. Enter the http address to the folder containing the ASP page in the URL used to open resulting ASP(X) page field.

Press “Next” to advance to the next page of the wizard.

Verify the generated web page

Press “Finish” to begin the conversion process. 
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After conversion, a “Messages and Errors” window appears. In most cases there are only informational messages. If there are warnings or errors, turn to the section on Error messages in the Troubleshooting chapter.

In most cases, the generated web page is automatically opened in your default web browser. Verify the results of the conversion. SpreadsheetConverter provides numerous options that may help you tailor the conversion process and its results. In many cases, it’s easier to change the settings in SpreadsheetConverter and rerun the conversion than to manually modify the generated web page. 

The SpreadsheetConverter menu

During installation, SpreadsheetConverter installs itself as a separate menu in Excel:
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The menu can be used to initiate the following:

· Convert – starts the SpreadsheetConverter conversion wizard. 

· Last error report – opens the error report from the previous conversion. 

· Mark input cell, Create one of several options, Create Boolean control –used to simplify creation of advanced user interfaces with checkboxes, drop-down menus, radio buttons etc. These are describe at Creating better user interfaces 

· Options > Disable autostart – removes the SpreadsheetConverter menu from Excel. To install the menu again, click Start > Programs > SpreadsheetConverter > Install SpreadsheetConverter into Excel. 

· Manual (Acrobat PDF) – opens this document in your pdf reader. If you don’t have a pdf reader you can download the free Acrobat Reader from www.adobe.com. 

· Manual (HTML) – opens this document in your web browser. 

· Enter license key – allows you to enter your SpreadsheetConverter license key and unlock the application. 

· Purchase full license key  – opens a web page where you can purchase a license. Note that this entry will still be there after that you have registered your copy. 

· Purchase upgrade license – If you have version 2 and want to upgrade to version 3, you can buy a license here. 

· Check for update. – checks if your installed version is the latest version. If it isn’t, you will be told 

· About – some brief facts about SpreadsheetConverter. 

Tips, tricks and recommendations

Use cell formats for numbers and dates

When Excel formats a cell containing a number or a date, it uses a default display format unless you’ve selected a specific number or date format for the cell. However, Excel’s defaults may not be suitable when the spreadsheet is converted to web format and viewed through a web browser. If a cell looks strange in your browser, e.g. has too many or too few decimals, just select a number or date format for the cell in Excel using Format > Cell > Number and it will look the same on the web page. 

Use drop down lists instead of text input 

If you want your users to be able to select from a list of given values in a drop​down menu, use Data > Validation > List in Excel to create the menu before you convert the spreadsheet to web format. 

Use list boxes

If you want your users to be able to select a single value from a list of given values in a list box, use Data > Validation > List in Excel to create the menu and let it span over several merged rows.

Use checkboxes

If you want a checkbox in a cell, use the values “true” or “false” (or the equiva​lent in the language supported by your Excel version). SpreadsheetConverter will automatically present the cell as a checkbox.

Use multi-line input boxes

An input cell which spans over several merged rows will become a multi-line input box on the web page. This field can be scrolled.

Use charts to present data graphically

If you place a pie, bar, column, line or scatter chart in a worksheet, SpreadsheetConverter will include the chart on the web page. To add a chart to a spread​sheet, use Insert > Chart… in the Excel menu. To modify the appearance of the chart in Excel, click on the chart and use the Chart menu. 

During conversion, SpreadsheetConverter reads the chart definitions in the spread​sheet and creates a Flash version of the chart. As in Excel, the Flash version of the chart is dynamic and immediately reflects changes made to the data in the work​sheet. 

Avoid horizontal layouts

Spreadsheets are often designed with a horizontal layout, e.g. with a lot of sideways scrolling from column to column. This kind of design is rarely used on the web. For the most web-like appearance, consider designing your spreadsheets so that they don’t require horizontal scrolling.

Adding a converted spreadsheet to your web site

Basic steps

The tools you are using, e.g. your content management system and the editors and other support programs you use, have a strong influence on the steps required to publish a web page. However, there are three basic operations you always need to perform, regardless of your toolset:

Move the page to the web site

Ensure that the file is physically included in your web site, i.e. that it is located within the same folder structure or content management system as the other web pages in the web site. This guarantees that the page is physically accessible when requested by one of the users of the web site.

Insert the page into the site

Link the page to the rest of your site. You will need at least one link to the page so that users can navigate to it. If your web site has a menu or similar navigation structure you may want to insert it also on the SpreadsheetConverter page. 

Adapt the formatting of the page (optional)

Give the SpreadsheetConverter page the same look-and feel as the rest of your site. Open the SpreadsheetConverter page in your favorite web page editor and format it so that it looks like the other pages on your web site. 

Contents of an SpreadsheetConverter folder

When you publish the web page on a web server, you must include all files in the folder created by SpreadsheetConverter. To avoid file name conflicts, we recommend that you upload the entire folder and link to the page inside the folder. 
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In the example above, a “mortgage.xls” spreadsheet has been converted to a “mortgage.htm” web page, which SpreadsheetConverter has embedded in a “mortgage” folder that also contains a diagram and an image file.

The “Powered by SpreadsheetConverter” image link

All web pages created by SpreadsheetConverter contain a small 334-byte image link with the text “Powered by SpreadsheetConverter”. An easy way to remove this image without modifying the html is to replace the image file with a different image file with the same name.

Adding an SpreadsheetConverter page to a FrontPage site

Here’s a step‑by‑step instruction on how to insert a web page created by SpreadsheetConverter into a FrontPage web.

· Select File > Import and press Add Folder. Navigate to and select the folder created by SpreadsheetConverter. Press “OK”. 

· If necessary, drag the imported folder to a suitable location in the folder structure for the web. Modify the folder name if necessary. 

· Open the folder and open the SpreadsheetConverter web page in the FrontPage editor. Note that the web page has very basic formatting and contains no navigational bars. From the menu, select File > Properties and set the page title (appears in the title bar of the web browser). 

· If all pages of your web have common elements, e.g. a common heading and/or footer section or a navigation tool, ensure that these common elements are inserted also into the new page. Note that there are many ways to perform this step depending on your preferred toolset. 

· If the formatting is incorrect or the page doesn’t recalculate, you have been affected by a minor bug in FrontPage. Some versions of FrontPage insert an extra </head> tag when importing pages. To correct this, turn to the editor’s HTML view of the page. Verify that there are two </head> tags in the document. If there are, move the <body> tag so that is it located immediately after the second </head> tag, then delete the first </head> tag. 

· If you web uses themes, select Format > Theme. Select “Selected page(s)” and apply the default theme (at the top of the list) to the new page. Press “OK”. 

· If your web uses shared borders, select Format > Shared Borders. Select “Current page” and “Reset borders for current page to web default”. Uncheck all other options. Press “OK”. 

· Select the Navigation view and drag-and-drop the inserted page to the correct location in the navigation structure. 

· Still in the Navigation view, click on the inserted page and give it a page banner text (appears in the page banner). 

· Still in the Navigation view, right-click on the page that you just moved and make sure that ’Included in Navigation bar’ is selected. 

· When you’ve done all the necessary modifications to your site, publish it to the web server. 

Now, your page should appear like the other pages in your web site and the navigation structure should include the new page. 

Creating an interactive form as a web page

Basic steps

Microsoft Excel together with SpreadsheetConverter provides an easy way to create interactive forms on the web, and subsequent updates can be performed very quickly. 

Some examples of forms that you can create using Excel are: expense reports, online reports, surveys, order forms, registration forms, reservation forms, sweepstakes, employment applications and product registrations. 

It is very easy to publish an interactive form on the web using SpreadsheetConverter. Just modify the spreadsheet, start the SpreadsheetConverter wizard and only seconds later an interactive web page is created and ready to be published on your web site. 

Using basic forms support in the web server environment, incoming data can be stored on the server in a flat file or database. If the volume of data is low, you can also have each completed form sent by email to a predefined email address. 

Regardless of your toolset, four basic steps are required to create interactive forms with SpreadsheetConverter:

Create the form using Excel

The row/column layout of Excel makes it very simple to create forms. For an order form, one column could be used for quantity and one for unit price. In a third “item price” column you may automatically want to multiply unit price by quantity. At the bottom of the “item price” column you may want a cell holding the “total price”.

When converting forms, SpreadsheetConverter may have difficulties determining which cells to use for input. To avoid errors, you should designate all input cells manually, e.g. using cell coloring (see Select the input cells above). 

When a web user has completed the form and the data is sent back to you, the form fields are returned one by one in text format. For readability purposes, you may want each field in the response to be clearly labeled. Otherwise, SpreadsheetConverter identifies each input field using its row and column number in the spreadsheet. To assign an explanatory name to each input field, select the cells one-by-one in Excel and use Insert > Name > Define. 

Convert the form to web format using SpreadsheetConverter

SpreadsheetConverter identifies the input and output cells, and converts the Excel sheet to web format. Every time the user advances from one form field to the next, cells like “item price” and “total price” are recalculated with the latest information.

Establish the link between form and server

The SpreadsheetConverter toolbar includes an optional Submit button for simple implementation of intelligent web forms with SpreadsheetConverter. The Submit function can send the submitted form contents to you in an email. Since the generated web page is a standard html form, you can also use a standard html forms processor on one of your own network servers. See Submit parameters above for details.

Publish the form on the web server

Once the html for the interactive web page has been created and tested, it must be placed on the server and made available for users of the web site. This process is described in the section Adding a converted spreadsheet to your web site above. 

Creating a web form using FrontPage

To create a web form to be used by a web server that supports the FrontPage Server Extensions, e.g. Microsoft Internet Information Server or the Apache server, follow these steps: 

1. Create the spreadsheet using Excel. 

2. Name the input and output cells in Excel using Insert > Name (this step is not mandatory, but makes the result easier to understand). 

3. Configure submit on the Presentation and Interaction page of the SpreadsheetConverter wizard and select ‘I have prepared my own webserver to accept submits’. Leave the URL field empty; Frontpage will fill in the necessary information. 

4. Convert the spreadsheet to a web page using SpreadsheetConverter. 

5. Open the resulting web page in FrontPage. 

6. Place the cursor somewhere near the input fields, click the right mouse button and then select 'Form properties'. 

7. Select the handling of the form that is appropriate to your needs. The minimum you must do is to select 'Send to' and enter an email address. 

8. Publish the web page onto your web server using the instructions in section Adding an SpreadsheetConverter page to a FrontPage site above. 

Creating better user interfaces

SpreadsheetConverter supports drop-down menus, radio buttons, checkboxes, listboxes, multi-line input fields. 

Cell-based controls versus floating controls

If you want to ask the user for a number, you can say that a cell is an input cell, and you will get an input field on the web page. We call this input cells cell-based, since it’s location is determined by a cell. 

On the other hand, you can create a drop-down menu by selecting a combo box from Insert-Toolbar-Forms. The control will place itself ontop of the worksheet.  We call such a control a floating control.

Most controls can both be constructed as a floating control and as a cell-based control. The are two exceptions: plain input cells for text and numbers, which always are cell-based, and radio-buttons which always are floating.

Floating controls always needs a linked cell. The selected value will be stored in this cell.
 

	 
	Cell-based
	Floating

	Input cell for text or number
	Mark a cell as input cell
	N/A

	Checkbox
	Mark a cell as input cell and set it to TRUE or FALSE
	Select a checkbox from View-Toolbar-Forms and set the linked cell

	Drop-down menu
	Create a list using Data-Validation-List
	Select a combo box from View-Toolbar-Forms and set the linked cell

	Radio buttons
	N/A
	First create a frame using View-Toolbar-Forms, then fill it with radio buttons from View-Toolbar-Forms. Make sure that all radio buttons are completely inside the frame. Set the linked cell of each radio button to the same cell. Note that frame will not be shown on the webpage, but it is necessary for grouping the radio buttons

	List box
	Merge the cells on two or more rows and create a list using Data-Validation-List
	Select a list box from View-Toolbar-Forms and set the linked cell. The selection type must be set to single.

	Multi-line input cell
	Merge the cells on two or more rows and make them input cells.
	N/A


Which should I prefer: cell-based or free-floating?

It is a matter of taste. The web page will look the same. The advantage of the free-floating is that the spreadsheet will look more like the final web page. The advantage with cell-based is that it is easier to create and maintain many controls. 

Also, free-floating controls might require you to select Layout=Fixed in order to get the placement correct on the web page.

Tools to simplify advanced input controls

You can create controls like radio buttons, drop-down menus as described above. In order to make it simpler, we have added some commands to help you.

Mark input cells…

Assuming that the cell contains a constant value or is empty, then the cell can be identified as an input cell in three separate ways:

1. It is used by a formula and you have selected Automatic detection of input cells. (See Select the input cells) 

2. You have set the background color of the cell and selected Select input cells using coloring. (See Select the input cells) 

3. The cell is unlocked and you have selected Unlocked cells are input cells. (See Select the input cells) 

Setting the background color of a cell or unlocking it can be done using the Excel command Format-Cell, or you can use Mark input cells…

First select the cell or cells that you want to be input cells, and then select Mark input cells… from the SpreadsheetConverter menu.
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The cells C2,D2 andE2 will be unlocked. 

If you select Color the input cells, they will be colored using the same color you selected in Select input cells using coloring. (See Select the input cells)

If you select Merge and left-justify the cells, the cells will become one single large input cell, otherwise, there will be three input cells next to each other.

Create one of several options…

Before you select the command Insert one of several options you have to select a cell in your worksheet. The control will be placed here. That cell should be empty.

If you select the cell F3, select Insert one of several options you, enter Always, Maybe, Never and select ‘Try to avoid free-floating Excel controls’, the wizard will place a drop down list in cell F3.
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Select cell F8 and select Insert one of several options again. Select Radio buttons, unselect Try to avoid free-floating Excel controls and set the linked cell cell to F4.
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The final result will be a drop-down menu in F3, three radio buttons in cell F8 and downwards. The cell F4 will contain 1, 2 or 3 depending on which radio button is selected.
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Create Boolean control…

This wizard creates checkboxes and radio buttons with 2 alternatives.
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Naming cells

If you use the free service to handle submits, naming cells is very important. Unless you have named the input and output cells, the names will look like p1A1, which means Sheet1!A1. This will make the email hard to understand.

You can either name a cell using Insert-Name-Define in Excel, or by selecting the cell to be named and enter the name into the little box in the upper-left corner.

In the following screenshot we selected cell F4 and entered the name how_often into the naming box.
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In order for names to be used by SpreadsheetConverter, the name should only refer to a single cell and only contain letters, digits and underscore. The name must start with a letter. Other names will be ignored.

Advanced topics

This section mostly contains information suitable for an advanced Excel user or web programmer. If you don’t belong to either category, just move on to the next chapter. 

Support for regional options and languages

Basically, SpreadsheetConverter tomats numbers and dates just as they are formatted on your local computer.

Regional number formats

There are many ways to format a number. In the US, the decimal separator is a point and commas are used as thousand separators, e.g. 1,234.56 is a valid number. In contrast, most European countries use comma as the decimal separator and either space or point as thousand separators, e.g. 1 234,56 is a valid number. 

When converting a spreadsheet to a web page, SpreadsheetConverter tomats numbers in your spreadsheet as defined by the cell format (Format > Cells >Number). 

You cannot change the decimal or thousand separators in Excel, however; it must be done using the regional options for the whole system. If you want to create a web page to be used by someone familiar with a different format, e.g. a Swede, you have to open the regional options control panel and temporarily change to another region (e.g. Sweden). Once you’ve created the web page, restore your original regional options. The numeric formats used in the web page remain unchanged (e.g. still applicable to Sweden). 

SpreadsheetConverter supports most currency formats, but currency symbols such as $, £, or € are not included. If necessary, put the $, £, or € into the cell immediately preceding or following the number.

Regional date formats

There are also many ways to format a date. In the US, dates are in the Month/Day/Year format, e.g. 5/04/04 is May 4, 2004. In contrast, most European countries write dates as Day-Month-Year with various separators, e.g. 04.05.04 for the same date. Some countries even use the Year-Month-Date format.

When converting a spreadsheet to a web page, SpreadsheetConverter basically formats dates as defined by the cell format (Format > Cells >Number). For input cells, the following restrictions apply:

1. The ordering of month, day and year is fixed. If you create the web page using US settings, only the month-day-year order is supported. If you create the web page using European settings, both day-month-year and year-month-day are allowed, but not the US format. 

2. Input cells may only use numeric date formats. You can use ”04/05/2004” but not ”4 May 2004”. 

Recommendation: to avoid confusion with an international audience, create three cells with drop-down lists: one to select a day, one to select a month and one to select a year. Then use the three values to create the date internally in Excel using the DATE function. There is an example of this on the SpreadsheetConverter web site at http://www.xleverywhere.com/manual/date_dropdown_list.htm.

National characters

SpreadsheetConverter supports Unicode for national characters. 

Inserting a spreadsheet on an existing web page

If you ever need to insert a spreadsheet on an existing page in your web, just follow the steps below.

1. Create the spreadsheet in Excel. 

2. Convert the spreadsheet to a web page using SpreadsheetConverter. 

3. Open the resulting web page in your html editor. 

4. Using your html editor, also open the existing page where the spreadsheet is to be inserted. 

5. In the <head> … </head> section of the SpreadsheetConverter file, locate the section beginning with <!-- Header start --> and ending with <!-- Header end --> and copy it (including the leading and trailing comment) to the end of the <head> … </head> section of the existing page. 

6. In the <body> … </body> section of the SpreadsheetConverter file, locate the section beginning with <!-- Body start --> and ending with <!-- Body end --> and copy it to where you want the spreadsheet to appear in the <body> … </body> section of the existing page. 

7. (optional) Copy the onload-event from <body into your <body-tag. Typically the onload-event looks like this:
<body onload="initial_update();document.formc.pA1A.focus();">
It initializes the form and places the cursor at the first field. 

 

Troubleshooting

Technical requirements

Requirements for running SpreadsheetConverter to create web pages: 

· English version* of Excel 2000, Excel XP or Excel 2003. SpreadsheetConverter version 2 still supports Excel 97. 

· Windows NT4, 2000, XP or 2003. SpreadsheetConverter version 2 still supports Windows 98 and ME. 

· Pentium-II or better, 64MB RAM, 50 MB free hard disk space. 

* SpreadsheetConverter also works with many localized versions of Microsoft Excel. Download the trial version and try it out. If the trial works, the full version will also work. 

Requirements for the end user accessing the resulting web pages: 

· Browser: Internet Explorer 5.5 and 6, Netscape 7, Mozilla, Galeon, Konqueror. SpreadsheetConverter version 2 still supports Internet Explorer 4 and 5.0, Netscape 4 and 6. 

· Live charts: Flash plug-in version 6 or later. 
In December 2003, 90% of all browsers supported Flash version 6 or later, see http://www.macromedia.com/software/player_census/flashplayer/version_penetration.html 

· OS: Windows, Linux, UNIX, Macintosh and many embedded devices, e.g. set-top boxes. 

Known issues

Support for Excel spreadsheet features

SpreadsheetConverter supports a major subset of the features available in an Excel spreadsheet, listed in Appendix 1: Conversion details. An updated list of currently supported spreadsheet features is available at www.spreadsheetconverter.com.

Support for Excel built‑in functions

SpreadsheetConverter supports a major subset of the built‑in functions available in Excel, listed in Appendix 2: Supported functions. An updated list of currently supported built‑in functions is also available at www.spreadsheetconverter.com. 

No support for Excel macros

SpreadsheetConverter does not support Excel macros.

Error messages

After conversion, SpreadsheetConverter displays a status window with all the messages generated during the conversion. This window is split into three panes: a top pane with all the messages; a middle pane with the full text of the currently selected message (in the top pane); and a bottom pane with the complete list of cells affected by the message. To navigate to a particular cell, simply click the reference to the cell in the bottom pane and the cell will be selected.

If an error or warning message was generated during conversion, your web page may generate incorrect results. You should always resolve such issues before using the page for calculations.

Below is a list of the most common messages and their meaning.

Informational messages

<Text format> does not work for in and out-cells.

Your spreadsheet uses a special text format for an input or output cell. Use a different format.

<Text format> not supported by HTML, using <text format> instead.

The former text format is not available for web pages and has been replaced by the latter text format.

Warning messages

Cells containing formulas cannot be input. Cell converted to output.

You have manually marked a cell as an input cell, but the cell contains a formula (beginning with “=”). Remove the formula from the cell or use another cell for input.

If you input dates, the format must follow <region> date format (<example>), since this is the standard format on this machine.

For input fields containing dates, the date format set in the Regional Options control panel must be used.

Error messages

Dates containing name of month, weekdays or AM/PM cannot be entered using text fields. Choose 24-hour clock and dates like 01/02/2003.

Excel supports many date formats, including ones with the whole or partial names of months, e.g. “April 21, 2003”. These date formats are currently not supported by SpreadsheetConverter to input fields. Use numerical date formats instead.

External file 'file name' referenced.

SpreadsheetConverter requires that all worksheets required for the conversion are part of the same file. If you get this error message, one or more cells refer to an external file. If the cell that is referenced contains a static value, just copy it into a cell in the file you are converting and use the copied cell instead. If you need an entire worksheet from another file, copy the requested worksheet into the file you are converting and try again.

Support

Reporting a problem

If you have any problems, please do one of the following: 

· Visit www.spreadsheetconverter.com and read the appropriate page of the Frequently Asked Questions (FAQ) section. 

· Send an email to support@spreadsheetconverter.com. 

· Use the form on our web site if we do not reply on your email within a working day. Spam-filters sometimes make email unreliable. 

We provide the best possible support, both for trial-users and customers. You should expect answers before the end of the next working day.

Support for server-based solutions

Using a server-based solution is inherently much more complex than using a client-based solution. Unfortunately, we are unable to support you in establishing a proper web server environment for web pages created by SpreadsheetConverter or by other means. Before you contact us regarding problems with server-based solutions, ensure that you are able to run all JSP or ASP example files provided with the web server.

Consultancy services

Do you have problem converting your spreadsheet into a web page? Our support is there to help you. However, support will only help you, not convert you whole spreadsheet. If you want a total solution, our consulting services are there to help you.  

Our consultants will deliver a ready web page, which can be used directly. The fee is $100 per spreadsheet. 

1. Send the spreadsheet to consulting@spreadsheetconverter.com 

2. Our consultant will take a quick look at it, and decide if we accept the assignment. 

3. If we accept the assignment, you will be asked to pay the fee using a credit card. 

4. We will start working and send you the result, i.e. both the adapted spreadsheet and the web page. 

5. If we fail, the fee will be reimbursed. 

If you later need to change the spreadsheet, you can either do it yourselves, or ask us for help again.  

Appendix 1: Conversion details

This chapter describes how various features of your spreadsheet are handled during the conversion to web format.

We are continuously adding new features to SpreadsheetConverter. If your spreadsheet uses a feature you need support for, please let us know.

Cell contents

Internally, SpreadsheetConverter separates cells into three types. In most cases, it is able to automatically determine the correct cell type for each cell:

· Input cells are modified by the user of the spreadsheet. The main issue with input cells is to avoid opening cells for input if they aren’t in fact used for anything. To handle special situations, the SpreadsheetConverter wizard allows you to use a special fill color to explicitly designate input cells (see the description of how to Select the input cells in the Using SpreadsheetConverter chapter above). 

· Output cells contain formulas beginning with “=”. Output cells are modified during recalculation of the spreadsheet. 

· Label cells are used for static information, e.g. row and column headings. The contents of label cells never change. 

Referencing cells

A cell that is referenced in a formula is always included in the conversion, regardless of which worksheet it is part of. This is true regardless of the “Select Cells” setting in the SpreadsheetConverter wizard. However, you cannot reference cells in other files.

Spreadsheet cells are automatically given names that are used when the cell is referenced on the resulting web page. If you have assigned explicit names to cells in Excel, these names are used instead of the automatic names if they confirm to the following rules: a) the name only contains a‑z, A‑Z, 0‑9 and underscore (_); b) the name begins with a letter; and c) the name is not a reserved word (e.g. new, function). Naming cells simplifies advanced use of SpreadsheetConverter, e.g. creating interactive web applications or interfacing to external JavaScript code. 

SpreadsheetConverter fully supports national characters using Unicode. 

Page formatting

File > Print area is ignored.

File > Properties: the Title field is used as the title for the web page. 

Format > Sheet > Hide is supported. Hidden worksheets are part of the generated web page, but not shown.

View > Custom view is ignored.

View > Header and Footer is ignored.

View > Zoom is ignored. If the spreadsheet is shown on your screen with the Zoom set to 70% or less, the web version will be significantly larger.

Cell formatting

Format > Cells >Number is supported with all options except Fractions (e.g. 1/256, 3/48). For input fields containing dates, the date format set in the Regional Options control panel must be used.

Format > Cells > Alignment > Horizontal: general, left, right, center, and center across selection is supported.

Format > Cells > Alignment > Vertical: top, bottom and center is supported.

Format > Cells > Alignment > Text control: wrap text and merge cells is supported.

Format > Cells > Alignment > Orientation is not supported since it isn’t supported by web browsers.

Format > Cells > Font: all options are supported. However, a browser can only use the fonts available in the client environment when the page is displayed. If someone using your spreadsheet on the web doesn’t have the Quake font installed it may be replaced with Helvetica instead, which of course provides a slightly more conventional look. For input fields, certain styles may not be used, e.g. superscript or strikethrough.

Format > Cells > Border: all options are supported except diagonal borders, which are unsupported in the web environment. There are fewer patterns available in a web browser, so you may find your favorite pattern replaced by a similar pattern.

Format > Cells > Patterns: Cell color is supported, but not patterns. 

Format > Cells > Protection: protection of worksheets including the Locked cell option is supported, but the workbook must be unlocked during conversion. The Hidden attribute is ignored. 

Format > Conditional Formatting is ignored.

Format > Style is ignored.

Insert > Comment becomes a tooltip. Note that some browsers have poor support for tooltips, which may make your comment hard to read.

Insert > Hyperlink is supported. For http links the referenced page is opened in a new window. SpreadsheetConverter also supports JavaScript links. The referenced script will be run in the same window, without restrictions, e.g. to open a pop‑up window. 

An input field containing true/false values becomes a checkbox.

Checkboxes created with View > Toolbars > Forms become checkboxes.

Dropdown lists created with View >Toolbars > Forms become dropdown lists.

Dropdown lists created with Data > Validation > List become dropdown lists.

Dropdown lists created with Data > Validation > List that span over several rows become list boxes.

List boxes created with View >Toolbars > Forms become lists boxes.

Checkboxes and dropdown lists created with View > Toolbar > Control > Control Toolbox or VBA are not supported.

Other Excel features

Data > most options are unsupported, except Data > Validation > Allow > List.

Format > Row: Row height is supported. Hidden rows are not shown on the web page, but the formulas are included if needed.

Format > Column: Column width is supported. Hidden columns are not shown on the web page, but the formulas are included if needed.

Format > Sheet: Hidden sheets are not shown on the web page even if you selected ‘Show All’ in the wizard. If hidden sheets are referenced, their formulas will be included but not shown onn the web page.

Insert > Function is supported for the functions listed in Appendix 2: Supported functions.

Insert > Map is not supported.

Insert > Object is not supported.

Insert > Picture is supported.

Tools > Goal Seek is not supported.

Tools > Macro is ignored.

Tools > Protection is supported, but the workbook must be unlocked during conversion.

Tools > Solver is not supported.

Tools > Track Changes is ignored.

Appendix 2: Supported functions

This chapter contains a list of the built‑in Excel functions that SpreadsheetConverter supports. Visit www.spreadsheetconverter.com for the latest updates to the list.

We are continuously adding new functions to SpreadsheetConverter. If there is a special function you need support for, please let us know. 

Arithmetic and operators

= 

> 

>= 

< 

<= 

<> 

+ 

- 

* 

/ 

% 

^ 

Logical 

IF 

AND 

OR 

NOT 

TRUE 

FALSE 

Text 

CHAR 

CLEAN 

CODE 

CONCATENATE 

DOLLAR

EXACT 

FIND 

FIXED

LEFT 

LEN 

LOWER 

MID 

PROPER 

REPLACE 

REPT 

RIGHT 

SEARCH 

SUBSTITUTE 

TEXT

TRIM 

UPPER 

VALUE 

HEX2DEC 

OCT2DEC 

BIN2DEC 

DEC2HEX 

DEC2OCT 

DEC2BIN

Math and Trig 

ABS 

ACOS 

ACOSH 

ASIN 

ASINH 

ATAN 

ATAN2 

ATANH 

CEILING 

COMBIN 

COS 

COSH 

DEGREES 

EVEN 

EXP 

FACT 

FLOOR 

INT 

LN 

LOG 

LOG10 

MOD 

ODD 

PI 

POWER 

PRODUCT 

RADIANS 

RAND 

RANDBETWEEN

ROMAN 

ROUND 

ROUNDDOWN 

ROUNDUP 

SIGN 

SIN 

SINH 

SQRT 

SUM 

SUMPRODUCT 

SUMSQ 

SUMX2MY2 

SUMX2PY2 

SUMXMY2 

TAN 

TANH 

TRUNC 

Statistical Functions 

AVERAGE 

AVERAGEA 

AVEDEV 

CORREL

COUNT 

COUNTA 

COUNTIF 

COVAR

HYPGEOMDIST

LARGE

MAX 

MAXA 

MIN 

MINA 

NORMSDIST 

PEARSON

RANK

RSQ

SLOPE

SMALL

STDEV 

STDEVA 

STDEVP 

STDEVPA 

SUMIF

VAR 

VARP 

VARA 

VARPA 

Information 

ISBLANK 

ISERR 

ISERROR 

ISEVEN 

ISLOGICAL 

ISNA 

ISNONTEXT 

ISNUMBER 

ISODD 

ISREF 

ISTEXT 

NA 

Lookup and Reference 

CHOOSE 

COLUMN 

COLUMNS 

HLOOKUP 

HYPERLINK 

INDEX 

LOOKUP 

MATCH 

ROW 

ROWS 

VLOOKUP 

Date and Time 

DATE 

DATEVALUE 

DATEDIF

DAY 

DAYS360 

EOMONTH

HOUR 

MINUTE 

MONTH 

NOW 

SECOND 

TIME 

TIMEVALUE 

TODAY 

WEEKDAY 

YEAR 

Financial 

DB 

DDB 

FV 

IPMT 

IRR 

ISPMT

MIRR 

NPER 

NPV 

PMT 

PPMT 

PV 

RATE 

SLN 

SYD 

Analysis Toolpak 

QUOTIENT 

NETWORKDAYS 

 

HTML Code
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">

<!-- saved from url=(0013)about:internet -->

<html><head><title>Book1.xlsx</title>

<meta http-equiv=Content-Type content="text/html; charset=UTF-8">

<meta name="GENERATOR" content="SpreadsheetConverter to HTML/JavaScript version 4.0.1 (build 951)" />

<!-- SpreadsheetConverter Header start -->

<!-- Parts of this page Copyright (C) 2002-2007 Framtidsforum I&M AB, Sweden -->

<style type="text/css"> /* Styles needed by SpreadsheetConverter */

.eebuttons {width:120px}*.ee100 { color : black; font-family : Calibri , sans-serif; 

font-size : 11.00pt; font-style : normal; font-weight : 400; 

padding-left : 1px; padding-right : 1px; padding-top : 1px; 

text-align : left; vertical-align : bottom }

*.ee106 { background : yellow; color : black; 

font-family : Calibri , sans-serif; font-size : 11.00pt; 

font-style : normal; font-weight : 400; padding-left : 0px; 

padding-right : 1px; padding-top : 0px; text-align : right; 

vertical-align : bottom }

*.ee108 { background : yellow; color : black; 

font-family : Calibri , sans-serif; font-size : 11.00pt; 

font-style : normal; font-weight : 400; text-align : right; 

vertical-align : bottom }

*.ee109 { color : black; font-family : Calibri , sans-serif; 

font-size : 11.00pt; font-style : normal; font-weight : 400; 

padding-left : 0px; padding-right : 1px; padding-top : 0px; 

text-align : right; vertical-align : bottom }

*.ee110 { color : black; font-family : Calibri , sans-serif; 

font-size : 11.00pt; font-style : normal; font-weight : 400; 

text-align : right; vertical-align : bottom }

*.ee900 { font-size : 10.00pt; color : #3333ff; 

font-family : "Arial", Sans-serif; border-bottom : 3px solid #3333ff; 

border-right : 3px solid #3333ff; border-top : 3px solid #3333ff; 

border-left : 3px solid #3333ff }

textarea {  overflow: auto; }

</style>

<style type="text/css" media="screen">

.eebuttonbar_top {margin-bottom:6px;padding-bottom:6px;border-bottom: 2px solid blue}

.eebuttonbar_bottom {margin-top:6px;padding-top:6px;border-top: 2px solid blue}

.eetabs {display:block;}</style>

<style type="text/css" media="print">

.eebuttonbar_top {display:none;}

.eebuttonbar_bottom {display:none;}

.eetabs {display:none;}</style>

<script language="javascript" type="text/javascript">

var co = new Object;

function recalc_onclick(ctl) {

  if (true) {

co.XLEW_1_2_2=eeparseFloat(document.formc.XLEW_1_2_2.value);co.XLEW_1_3_2=eeparseFloat(document.formc.XLEW_1_3_2.value);calc(co);document.formc.XLEW_1_4_2.value=eedisplayFloat(co.XLEW_1_4_2);

};};

var eeisus=1;var eetrue="TRUE";var eefalse="FALSE";var eedec=".";var eeth=",";var eedecreg=new RegExp("\\.","g");var eethreg=new RegExp(",","g");var eecurrencyreg=new RegExp("[$]","g");var eepercentreg=new RegExp("%","g");

var arr1xB2B3=new Array(2);for(var ii=0;ii<2;ii++){arr1xB2B3[ii]=new Array(1);for(var jj=0;jj<1;jj++){arr1xB2B3[ii][jj]=0}};var eecm1=new Array(new Array(arr1xB2B3,0,0,1,0));function calc(data){arr1xB2B3[0][0]=data.XLEW_1_2_2;arr1xB2B3[1][0]=data.XLEW_1_3_2;var cA4B=(sumgeneral(2,0,0,eecm1));data.XLEW_1_4_2=cA4B;};

 function myIsNaN(x){return(isNaN(x)||(typeof x=='number'&&!isFinite(x)));};function round(n,nd){if(isFinite(n)&&isFinite(nd)){var sign_n=(n<0)?-1:1;var abs_n=Math.abs(n);var factor=Math.pow(10,nd);return sign_n*Math.round(abs_n*factor)/factor;}else{return NaN;}};function sum2(arr,rt,rb){var sum=0;for(var ii=rt;ii<=rb;ii++){sum+=arr[ii]};return sum};function sum3(arr,rt,ct,rb,cb){var sum=0;for(var ii=rt;ii<=rb;ii++){for(var jj=ct;jj<=cb;jj++){sum+=arr[ii][jj]}};return sum};function sumgeneral(cnt,vsum,vcnt,x){var sum=vsum;for(var ii=0;ii<x.length;ii++){sum+=sum3(x[ii][0],x[ii][1],x[ii][2],x[ii][3],x[ii][4]);};return sum;};function eeparseFloat(str){str=String(str).replace(eedecreg,".");var res=parseFloat(str);if(isNaN(res)){return 0;}else{return res;}};var near0RegExp=new RegExp("[.](.*0000000|.*9999999)");function eedisplayFloat(x){if(myIsNaN(x)){return Number.NaN;}else{var str=String(x);if(near0RegExp.test(str)){x=round(x,8);str=String(x);}return str.replace(/\./g,eedec);}};

</script>

<!-- SpreadsheetConverter Header end -->

</head><body onload="initial_update();document.formc.XLEW_1_2_2.focus();"   >

<table id="_TRIAL_MSG" style='border-collapse:collapse'  border="0" cellspacing="0" cellpadding="2" bgcolor="#FFFFFF">

<tr><td width="484" style='width:363pt;' class="ee900">

The page as a whole or parts of it is only allowed to be used for evaluating  <a href='http://www.spreadsheetconverter.com/poweredby.htm' target='_blank'>SpreadsheetConverter</a> . All publishing on a webserver, for other purposes than evaluation, requires a license of  <a href='http://www.spreadsheetconverter.com/poweredby.htm' target='_blank'>SpreadsheetConverter</a> .

</td></tr></table><br />

<!-- SpreadsheetConverter Body start -->

<form id="formc" name="formc" method="post" action="http://www.spreadsheetconverter.com/mailer34/submit.aspx"> <div style="display:none"> 

   <input type="hidden" id="xl_spreadsheet" name="xl_spreadsheet" value="Book1.xlsx" />

   <input type="hidden" id="xl_client" name="xl_client" value="h4.0.1" />

<script language="javascript" type="text/javascript">

  var submitted = false;

  function check_submit()

  {

     if (submitted) {

        alert("You have already submitted the form.  Please be patient.");

        submitted = false;  /* reset if the user wants to submit again, for example due to failure */

        return false;

     } else {

        recalc_onclick('');   /* force recalc before submit */ 

        submitted = true;


document.formc.submit();

        return true;

     }

  }

</script>

</div>

<div class="eebuttonbar_top">

<input class="eebuttons" type="button" value="Update" name="xl_update_top" onclick="recalc_onclick('')">

<input class="eebuttons" type="button" value="Reset" name="xl_reset_top" onclick="reset_onclick('')">

<input class="eebuttons" style="margin-left:30px" type="button" value="Submit" name="xl_submit_top" onclick="check_submit();"  >

<input class="eebuttons" type="button" value="Print" name="xl_print_top" onclick="window.print();">

</div>

<div id="panel1" style='display:block'>

<table width="241.00" style='border-collapse:collapse' border="0" cellspacing="0" cellpadding="0" bgcolor="#FFFFFF">

<col width="113.00" />

<col width="64.00" />

<col width="64.00" />

<tr style='height:15pt'> 

<td class='ee100'>

Hello

World

</td>

<td class='ee100' colspan="2">

DataInput

</td>

</tr>

<tr style='height:15pt'> 

<td class='ee100'>

Enter<span>  </span>number1:

</td>

<td class='ee106'>

<input value="1" name="XLEW_1_2_2" id="XLEW_1_2_2" type="text" onblur="this.value=eedisplayFloat(eeparseFloat(this.value));recalc_onclick('XLEW_1_2_2')" tabindex="1"

style=' width:100% '

class='ee108'>

</td>

<td class='ee100'>

&nbsp;

</td>

</tr>

<tr style='height:15pt'> 

<td class='ee100'>

Enter<span>  </span>number2:

</td>

<td class='ee106'>

<input value="2" name="XLEW_1_3_2" id="XLEW_1_3_2" type="text" onblur="this.value=eedisplayFloat(eeparseFloat(this.value));recalc_onclick('XLEW_1_3_2')" tabindex="2"

style=' width:100% '

class='ee108'>

</td>

<td class='ee100'>

&nbsp;

</td>

</tr>

<tr style='height:15pt'> 

<td class='ee100'>

The Sum of 1 &amp;

2:

</td>

<td class='ee109'>

<input value="0" name="XLEW_1_4_2" id="XLEW_1_4_2" type="text" tabindex="-1" readonly="readonly"

style='overflow:hidden; border:0px solid #000000; width:100% '

class='ee110'>

</td>

<td class='ee100'>

&nbsp;

</td>

</tr>

</table>

<p></p>

</div>

<div class="eebuttonbar_bottom">

<input class="eebuttons" type="button" value="Update" name="xl_update_bottom" onclick="recalc_onclick('')">

<input class="eebuttons" type="button" value="Reset" name="xl_reset_bottom" onclick="reset_onclick('')">

<input class="eebuttons" style="margin-left:30px" type="button" value="Submit" name="xl_submit_bottom" onclick="check_submit();"  >

<input class="eebuttons" type="button" value="Print" name="xl_print_bottom" onclick="window.print();">

<span style="margin-left:60px;"> <a href='http://www.spreadsheetconverter.com/web-javascript-calculator.htm' target='_blank' tabindex='-1'>

<img style='vertical-align: bottom;' border='0' src='powered-by-spreadsheetconverter.png' width='50' height='46' alt='Design web pages using Excel'></a>

</span>

</div>

<script language="javascript" type="text/javascript">

 function reset_onclick(x){document.formc.reset();postcode();recalc_onclick('');};function postcode(){};function eequerystring(){var querystring=document.location.search;if(querystring.length>0){variables=(querystring.substring(1)).split("&");var variable;var key;var value;for(var ii=0;ii<variables.length;ii++){variable=variables[ii].split("=");key=unescape(variable[0]);value=unescape(variable[1]);if(document.formc[key]!=null){document.formc[key].value=value;}}}}function initial_update(){postcode('');eequerystring();recalc_onclick('');}

</script>

<input type="hidden" name="xl_aux" value="begin-base64 666 C:\DOCUME~1\A06F1~1.WSP\LOCALS~1\Temp\tmp39fdc7.t1

QlpoOTFBWSZTWSXuFJsABU1flHwyf////7/33u6////+QAAQAGAO/3eVeJ3r

rWX059vKvkXsjrz33ve98+tL7B5AA6U0l9OhQDouEkUajFJ+TU1PRim1PR6S

ep6aj0B6o0DTTBDQZDQNGIBKITTUzRMU3qKbEj1GankjIB6gGagaAAGQNAEk

CQmkyBPKbTREMnqZojT1MaR6h6JowjQMNQyDQSFFTzVMk9NQPU9INPUxNGmg

AAaAAaGho0AAbUqntU/VGTQPRqeppoA9IaBoAGgNBpoyGhpoABIkIAjQBMU9

GkyjTE9CmR6MkyGgMT0QAaMjij8Ll4HHxuQsAxBIE13vyE3Dzshj/7SUou65

KbO6Z2dqueE10jFnKqoqNV9QDg7DjuVFHcwiYVq43Pqz1UWwtSJWsoAxobHH

BsUBiW7DTVYBZriprDVQq0F9MTUCogkQQgdi0R6PQ0EjY5LjZbBjkzZwZuL4

FtvmOj853EXz5uPQWM35ZhdoBgaRxGLarEYP1bDvN4hOIbocVIpF4rIYLj/j

Ms4xBrZ1929/YZDOjHf5eHXGcuutKcGquxyGqUwdq10+j80rW/LXS3bk9uHb

GYOOgmQxmdKJK4SFD1vtgEGz8pfAgiEHpUj4XrHsUKFFVVTTawapYzWUpSoh

GRhpbdpOW3kQuSfak0hK5C1/jhOtOS5WdxKtO7ZD+7Y2INV4jpxWGbQKZ/kp

82MGEzpadL5gaUcL1/iWjPEtoxIZQG0+Xfm6ydMtFlajSaeG+HZK+e660C4a

omt0FdcWVKoRulK9RS28TkLsM5yOWWjRMsbSNNxcdeJW81x3d2RNnz8guluD

b49KypdenMtjrYfdC4GR8Fs6pVgbhmnU22Ouw+qyX7a8R4VikUcFQC5jiNvf

vOajZZnzdzTjnyzOUQOuxXT4zbuzhl7v06Q6Rr6uO7Dfq1JBkDQLUDEkSF5D

/Fye+2Snnsw206tZGtEy674UGnmtgaBSBAJAumLLQYUDkHbJWXjEBzo2NTRo

YSOLCTygb6OuWjUtOHf8kpnTbsa2MN6pgwzq2yN9rqVbnhYpU5gz+5ES8k85

XO0ptlrg67HlPOoYNDjJA3MU1Fw5c9a44tQvD2dh1MKV+K2+VqoX9K6LOy8q

nZ4stfq+spsjGWa4jPRTn6yk7nXbqpUpCyympylhV+2ZjTI/F+G0oTpGFQjx

5xDFnQXrXSLzGDiHtF9Ys4s5z+3P/CsVvNDQ8DPm50meEC01KdShR3ioL4Wi

amOkkZan5ZGn732+eXsXFnJcWmUGQyZXdx33eyiwjhFrJYYwI7q1b9+EJax8

1EelFjsIhJhmJ0xYuFKwLaqxcCI0tg5G1OFGimDttstEzLG6aaDMwRL0Zi54

2GsJi+OzFVhtZ/rgVLGcR7ZA4SJH3btHAyRYKorTaGj2C2dp7yJi3/AUDw0w

bRJVyZVxWbKyuuQ3xR1PetRQBiCkW3PYGCrZbbXJP2IEUICUjUVUVSZaiLAf

TGeHTfUoahIwlab0Yl1TzkxHBF8qfewuuFwvD2s88i+SOXZp+pRQg7NaGHIp

bGgYDTEplfBpkL7TNTYOQDmbrBLzsR8LBSRw3B7wWsh2Ub9BiXUkEvmPggY6

oZVPOuuMoNs+cZnKvo2fkrKYKiFKMMBNC8fdxRWet2CUtiryFnSZbV3KOVgM

bkvFsgwr0xa+I5Jtzd841uQ5d2MlPTtx/RQfxVeVL0VqAITDiYEEmC0MI4fP

87ZWEygocMRA0vUwtGATGihQJmvfd6/WqGabpE5YzCEupi9rbYwNg9KQ0MrO

4mPp3rA8iuZYkloQzJYzWRkSsgkwageJ6GKqLGDAXFe80LXLJSFrgKt2aYvU

qBFsasFrNwZXGWgx5YrVq9nMlqn6Htig3OdUj1JlJEdVWl0v7Oq1dYW3Fc5H

QZCzwwlKpKsrdRMGMLFC7JYKlZLPFFFBT2gyaZR6uTlitMHkviqFWdUCx4Jf

T3umwjLbQP1Y+7r3f31Uw5q+QQSGdmS7hPoOHGa61qhhgaS1ZdEzYe1kslMO

hdYgrxHNbXFgPVzzia4HnnOiV+xg0DFJAjRwkxLYdEVB2hL6NaKRzcqYNh/t

yUXmLq3NqqBlwCBBpjvA47pxloutTeWV3dlgfYQ1ZGbRzUS4+uffq3GevfbV

vDcUHdEqe4QX32kkkkccklwg19DIHAOvkZO6dzK3UyAOovImXFL2SgeMKajZ

nQOCZQfvi5xxSMMj63NXNgYn2jI+8jxr8MxZCYSJc9Bul/LgTVEiN4nKAR9a

4qYKYpaTRIRKAgRU6UeK+BgRL20mtR/qsHhUIBIxCLjQkg5E2UjycalZSLPl

H8dmVLOMNCBYRHKG8wob6mqLkhndhtJU6WkFwjCWoRksaYmsoM8IeKI2gokY

twqXkAHHxzwds5iIYOLEdDIdPjf2UQQjayrL8PzASkqreK2ahlIE9nbXMoBi

KrKkAO3cc/tu0YM8lgXz4ORkVFtSRCIgDBSKIRtG9aQbShr7aofDdSGKUFEr

xGqmkEyeho5iYpMDMLJJ7p8KCbgtcDagqdJbUQQyakPFIaHJQ05IqdTKAoLr

zc+IV6uVkK9QLgUGoFiEkoXU4tbKQ3g0hjnHT/coy25jEyhANIlkpPL8Ra0d

Xdv5yiRupDk48vS3uop0scq+JlBxk27iC8dyOpCKiBp2Xp0R1nQMrgKeIMVK

dBIhwUoYChMQKonlGAhQPeN3giiJWNQII0aaWUI2FrYKQCpEsSA7ewBsbG23

2MbG2B06hvxPRyUK+CJj63pSLRihVBf1awJI/SlkitFXDHd8xIL/tW9Vu+Zy

MVX2G970EEvFcK0Y/eojLljDlLXymBKUxMxnJDWov1hYWCqitoRLmjCfZPTO

bbdxG4YvDTfSxaR2g4QNGohA2WAthUI0BLAHZCy0TRyDGzqwTTBswh6ebgRT

SF+0aJp9C5MaaaYwMwtiW2Zg1ywG/rcBaNYZMEgbEbbQhKu6BBCR5ewYqh5w

0pA0MS2lYtyuaODSHj9Kk2Y6qLSgPgCuosPCkhdtAjmkG4Ly+ltwZIyQLmQB

cdEMTSFWB3KWKRMj8KHVybZYkcEDB1iNLZMRUj+ojt4YPiLVG1HIKF2TNGcW

lIY+oce5bssUKaXC25IJIDKq9Hm+T7oNuYRu2FjJjS60Y4kkVhgwmL0gaFzX

du4hicTHe00jZ75CApVUSNBRctTNU4SlqhF0H5REhnnMyMUwsC9AthQRWhW9

PBE7M0lAwB5nCcM+U1JY96tvsrUIpikFyTJJE7yv6s1YaVWwy2dBGa8rA85U

iyxg1BPWTSFUGCVypfrcIWsICUkZElANEt7R38E5hIRektZJB4yMJExYgGCh

ddVDRbj3iIIFXEAzDDuOzKJIAaLjlMah0Pa03TYdFEYJJgeNNILhKxNFnxlw

qBKstrKy/4yp1NFiOLAVasUIYWh74Vo16YKfyrQqxEhWNyG1oHkSGBQOvxHi

sva/IuSWvDSDAziXYQcPHS93JumgM1xUq/MlCFfvYKEMNFjEoAYMUHiSGB2A

y8pRBmEj6LBiYms5MSjIVFY0qqg5jBPo+qLQQxHHcIhq1yA9+NEpkuxmCICo

1pHejM4hDPPsU+ZzJHhj8Y2wjAgJpeTkc2pnuO8Ph7RgiisEZ2ebXrw82fGr

dqWa4+hAxZ9xqmMNUR9QZ7ReyI3xmEq1DbIYXtsYM3gfJynSMEWrUUDENjYh

wghkib1AYRjJJSGyOoaSk5TImJqbQxmwcUQTKCjK/RGG4VFMtmRwUzPenwoD

FrxRnu1AimCGyDW37paOsr8W6FLrxJR41meb6WpSzmlBwQ0vXIWXyBeGpB8p

tRrQG7e0gYK30fKbLuWRXkIyCIStZdHAXDoRJnCoSjruSah+GHxKkYBskTIm

sDogTo5B6xxUYig4+CvS8pi3Bh02gw7Ba8/xN8BZ7swVtFi9Qg0S0FyqxuFN

K5WmTyUFwjMdBos0W48VJAspTIXaEdb6dhk1cjMqB6RpNmSZnzskyXaPCmC+

mZziAow1azd3y3mzxqabFKaAp9a0yh36m+rKxyKyiXTMEl7BBO+i5kUOVFYi

yBIbsaCSV4YLCusmMHNxYTrJ44IqQ0Fzo1Dhl6MwbzcTM0wzokKgKgKoLEzo

DdqzJJrb2LhgMhJ1rrR3GMCioNo9xYVGJgL1XG0SY5xlonM2pXhv1AI5hzSa

ruZMVobQL0RtkvSmtOBo0FWSNSAySRoFUCtSFdakF1etcDhWVjQt2agMYJsD

8UM7YNZopZYCl9jKIJBzEsUdhwCeC0bwWVpSaJCVnVkkjcgg2HMK8WhQu5vr

baG0b0mdrZRqElDjy/PS5jMuItkSTMI+tfbEIvXMQwuWZzj0RASDNdCXjHMs

RYjalua1JZmapCU8wW4ekVdgU9mILcQlIAu5C4PoD6gkDFSTnIO8kZjmCXgw

R13eJHWKoF9iYNDGWNtJtEM+/5nUr5WGteONlOfQznxWTGTdouXQUZTsSj/x

4j/i7kinChIEvcKTYA==

====

">

</form>

<!-- SpreadsheetConverter Body end -->

<noscript>The browser does not support JavaScript. The calculations created using  <a href='http://www.spreadsheetconverter.com/poweredby.htm' target='_blank'>SpreadsheetConverter</a>  will not work. Please access the web page using another browser.<p></p></noscript>

</body>

</html>
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